Midlife Riding

Forum Replies Created

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • in reply to: Mashup not linking to posts/pages #14644
    Midlife Riding
    Participant

    That did it! It is working with my theme and plugins and now works as it should for posts/pages and the hooks.

    Don’t know how I got mixed up with adding “mappress” to the shortcode. A lot of wasted time there. Thanks for your help!

    in reply to: Mashup not linking to posts/pages #14639
    Midlife Riding
    Participant

    Got some time to mess with it some more. Tried the workaround. New static front page with custom template.

    DOES work:
    <?php echo do_shortcode(‘[mappress mapid="2"]‘); ?>

    DOES NOT work:
    <?php echo do_shortcode(‘[mappress mashup="all"]‘); ?>

    So to clarify:

    mapid codes work fine throughout the entire site.
    mashups only work properly in the widget.
    mashups only displayed the map (without links) using the hook system.
    Embedding mashups directly into posts/pages/templates does nothing.

    I’ve disabled all plugins and reverted back to the default theme. Sending you admin details now to help me figure this thing out.

    in reply to: Mashup not linking to posts/pages #14619
    Midlife Riding
    Participant

    Perhaps it’s not the hook system at all.

    • Widget works fine.
    • mashup code injected to content_start hook on hompage works except converting titles/links
    • mashup code added to a page does NOT work at all
    • mashup code added to a post does NOT work at all
    • mapid code injected to content_start hook on hompage works except converting titles/links
    • mapid code added to a page does work except for converting titles/links
    • mapid code added to a post does work except for converting titles/links

    Let me know how to submit login details for my site.

    in reply to: Mashup not linking to posts/pages #14618
    Midlife Riding
    Participant

    I found out the issue. Now to find a work-around.

    My template (Themify iTheme2) provides a hook system to inject HTML/shortcodes/whatever and provides the ability to set it for different conditions/taxonomies. I used that to inject the mashup code and a little blurb of text into the “content_start” hook location with a condition to only show on the homepage. Like I said, everything else is working with the map except it’s not changing the POI names to the post titles and linking them as set in the master settings.

    The kicker is, if I add a mashup map with the widget block, it works just fine. I just don’t have any way to make a widget block look good and work for my purposes. The hook approach I’m using does what I want but is apparently breaking that part of the MapPress plugins’ features.

    Now I guess I need to get creative and find another way to add that mashup as the #1 content on my homepage ONLY. That or I’d be willing to pay/donate for some assistance getting the mashup to inject perfectly with the hook system.

Viewing 4 posts - 1 through 4 (of 4 total)