Zoom levels not working with Satellite maps + Formidable

Home Forums MapPress Support Zoom levels not working with Satellite maps + Formidable

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #15176
    invisionstudios
    Participant

    Trying to display a map in satellite view, with map generated via Formidable form. It will display sat view, but it’s at zoom level… maybe 8? I’d like it to be much closer, like 20, but it’s not working.

    This works in a regular post:
    [mappress mapid=”1″ zoom=”20″ tilt=”45″ maptypeid=”satellite”]

    But in a Formidable View (custom view from forms data) with this shortcode:
    [form_to_mappress address1=”[175]” tilt=”45″ maptypeid=”satellite” title=”Your Property” body=”[175]” directions=”none” zoom=”20″]

    Surprisingly the tile works with the satellite view. Any thoughts on how to fix?

    #15178
    Chris
    Keymaster

    Hi,

    What you may be seeing is actually a limitation of Google maps: the maximum zoom for satellite images is often much lower than for road maps.

    I think this is because they don’t have satellite imagery beyond a certain level. The maximum will also vary from one place to another, depending on how detailed the images are at that location.

    #15179
    invisionstudios
    Participant

    But I can zoom in manually after the map loads? Shouldn’t I be able to set the zoom level before it loads? I can do it with a manually generated map.

    FWIW, I’m trying to zoom in to view individual properties as close as possible.

    #15180
    Chris
    Keymaster

    Are you looking at exactly the same location in both instances?

    I don’t know what the form_to_mappress shortcode is doing, but it must be creating a MapPress shortcode at some point. Is it possible it’s not passing through the zoom level setting to the MapPress shortcode?

    If you could provide a URL of a working map and a URL of a non-working map at the same location, I can at least tell you if the non-working version received the zoom setting.

    #15182
    invisionstudios
    Participant

    The code is generating a map based on a Formidable form input, so it’s different each time. This is all generated using a Formidable View. Based on your request, I took a look at the code and discovered it was passing ‘null’ as zoom.

    I just took a look at the ‘form_to_mappress’ code that I loaded in my theme’s functions.php file and saw that it wasn’t passing any sort of zoom or tilt level. I fixed it by adding values to the shortcode array and to the map output:

    <?php
    
    /* SHORTCODE FOR MapPress + Formidable Pro connection */
    add_shortcode('form_to_mappress', 'form_to_mappress');
    function form_to_mappress($atts) {
         extract(shortcode_atts(array(
    	      	'width' => 425, 
    		'height' => 350,
    		'title' => '', 
    		'body' => '',
                    'address1' => '', 
    		'address2' => '', 
    		'directions' => 'none',
    		'zoom' => 20,
    		'tilt' => 45
         ), $atts));
    
         $mymap = new Mappress_Map(array('width' => $width, 'height' => $height));
         $mypoi_1 = new Mappress_Poi(array('title'=>$title, 'body'=>$body, 'address'=> $address1));
         $mypoi_1->geocode();
         $mymap->pois = array($mypoi_1);
         if($address2 != ''){
           $mypoi_2 = new Mappress_Poi(array('address' => $address2));
           $mypoi_2->geocode();
           $mymap->pois = $mypoi_2;
         }
         return $mymap->display(array('directions' => $directions, 'zoom' => $zoom, 'tilt' => $tilt));
    }
    /* END SHORTCODE MapPress */

    Now it’s outputting exactly what I want, a close-up view of a specific property address input by the user. If there isn’t a 45 degree tilt view, it defaults to overhead, but the zoom level is exactly what I want.

    Thanks for your assistance. Great support, as always!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.