Slow loading of maps

Home Forums MapPress Support Slow loading of maps

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #11646
    HDaniell
    Participant

      Hi there,

      My mappress mashups and single maps are taking a really long time to load.  The rest of the page loads, but the maps take a good 10 seconds longer.  I’ve tried different internet connections, different browsers and different computers.  Some are better than others but it all seems to be slow.  Any suggestions?

      The website is http://outsidethehorsebox.com

      #11651
      momofone
      Participant

        I have also noticed that Google maps seem to be loading slower than normal in the last 48hrs.  Don’t have any mashups, but my single maps are noticably slower, sometimes they don’t fully load leaving a blank/empty square on the map.

        #11652
        Chris
        Keymaster

          Hi, it also seemed to me there was some slow down with Google yesterday.


          @HDaniell
          : on the home page the maps are each showing about 120 posts worth of locations.  The plugin has to read and format each post for output, so the time taken is primarily the time to display 250 posts.

          You can speed up the widgets quite a bit by limiting the number of posts returned.  Try setting “posts_per_page=50” or a smaller number to limit the maximum number of posts.  Or, if you can categorize the posts into sub-categories (or tags) you can select a smaller set of data.

          For the home page in particular: the markers in the widgets are probably too small for anyone to click anyway.  Instead of showing a dynamic map, take a screenshot of the map image and make it clickable; when users click the image they can be taken to the ‘event information’ page to get the details from the (slower) ‘live’ map.

          #11654
          HDaniell
          Participant

            Thanks Chris I will try the screen shot with the homepage.  It is happening as well with just single point maps (in fact it’s taking just about the same amount of time as the mashups), but hopefully this is just Google?

            #11661
            Chris
            Keymaster

              Hi,

              That is strange, maps should normally load in < 1 second.  They can appear slower if other scripts are executing from the theme or other plugins.

              You can check if it’s something else by deactivating ALL of your other plugins and switching to the 2012 theme for a few minutes. If you get the site in that state, and it still seems slow, send me an email with the contact form and I’ll trace it for you.

              You can also try the MapPress setting to load the maps last (in the bottom ‘misc’ section).  That should prevent the map loading from delaying other scripts on the page.

            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.