Remove google POI

Home Forums MapPress Support Remove google POI

Tagged: 

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #13301
    roamingk
    Participant

      Hi,
      Is there any way to remove the Google Layer of poi.business… I dont want their links to hotels etc..coming up on my maps.

      Keith

      #13303
      Chris
      Keymaster

        Hi,

        Google has recently made it so those POIs are always clickable. They’ve refused to fix it, you can see the bug report here if you’re interested.

        One workaround is to use a styled map to hide the business POIs. Google’s own styling tool allows you to select POI layers and hide them. Please see the MapPress documentation for more information about how to enter map styles in the settings.

        #13304
        roamingk
        Participant

          Ok, I read the documentation, but where in Mappress do I ?

          Copy and paste it into MapPress.

          #13310
          Chris
          Keymaster

            On the settings screen – there’s a style maps section where you need to paste your json.

            #13323
            roamingk
            Participant

              Sorry, I have the JSON done.. but I must be missing something.
              I am on Version:2.38 PRO
              And when I go to
              /wp-admin/options-general.php?page=mappress

              I don’t see anything tat says “style maps”

              Sorry.

              #13325
              roamingk
              Participant

                Sorry again, I upgraded to the latest version and now I have it.

                I got the following json from google:

                [ { “featureType”: “poi.business”, “stylers”: [ { “visibility”: “off” } ] } ]

                I added it and created a layer called nopoi

                Now what do I do. Where do I put that style?

                Thanks

                #14127
                grego3781
                Participant

                  Hello,

                  I just purchased the PRO version of this plugin and am trying to do exactly what roamingk is trying to accomplish.

                  Can we get a response?

                  thanks!

                  #14128
                  roamingk
                  Participant

                    Its quite easy…. just go to settings and under css add the following:

                    [ { “featureType”: “poi.business”, “stylers”: [ { “visibility”: “off” } ] } ]

                    (giving it a class name .

                    Save the settings.

                    Then scroll down to the css setting and from the drop down select your class name and apply it. Click save on the settings… the poi premium lists no longer appear.

                    #14129
                    grego3781
                    Participant

                      That did the trick.

                      thanks!

                    Viewing 9 posts - 1 through 9 (of 9 total)
                    • You must be logged in to reply to this topic.