POI tooltips not working

Home Forums MapPress Support POI tooltips not working

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #14015
    vcrossley
    Participant

      Hello,

      I seem to be having trouble with displaying the POI’s. For example, in this article: http://offmetro.com/ny/2013/10/22/things-to-do-in-stockbridge-ma/

      If you look at console, it gives me the error below when I click on the markers:

      Uncaught TypeError: Cannot call method ‘close’ of null mappress.min.js?ver=2.40.7:1
      openInfoWindow mappress.min.js?ver=2.40.7:1
      openPoi mappress.min.js?ver=2.40.7:1
      mapp.Poi.open mappress.min.js?ver=2.40.7:1
      (anonymous function) mappress.min.js?ver=2.40.7:1
      O.trigger main.js:15
      KP.(anonymous function).e VM956:32
      (anonymous function) VM957:13
      O.trigger main.js:15
      H.rc VM954:128
      H.fm VM954:127
      (anonymous function) main.js:11
      O.trigger main.js:15
      H.zk VM954:113
      (anonymous function) main.js:16

      Thanks for taking a look at this!
      Vince

      #14017
      Chris
      Keymaster

        Hi,

        I think this is because the theme or one of the plugins is including a very old version of jQuery from the google repository. WordPress is loading the current version of jQuery (1.10.2), but this line is subsequently also loading 1.5.1:

        <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.5.1/jquery.min.js"></script>

        You’ll need to remove that line or update it to 1.10.2. It may be coming from the theme or from a plugin. You can check by switching to the standard 2014 theme for a moment, or by temporarily deactivating your other plugins to see if that line disappears.

      Viewing 2 posts - 1 through 2 (of 2 total)
      • You must be logged in to reply to this topic.