mashup not showing a specific custom post type

Home Forums MapPress Support mashup not showing a specific custom post type

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #10240
    asafche
    Participant

    mashup not showing a specific custom post type.

    i have eight custom post types, but the items of one of them won’t show in the mashup.

    all the rest do.

    how come?

    need urgent help with that.

    thanks.

    #10243
    Chris
    Keymaster

    Hi,

    What version of MapPress?  What’s the mashup shortcode you’re using?

    As a general tip, you can use ‘post_type=xyz’ to select a post type or ‘post_type=any’ to try all post types.  Also, you need to specify ‘posts_per_page=-1’ or your blog will limit the number of posts retrieved.

    #10247
    BradSiegfried
    Participant

    Don’t forget to tick the box for that post type in MapPress Basic Settings.

    #10248
    asafche
    Participant

    Of course, the obvious has been done.

    1. the checkbox for all of the custom post type are checked at the setting page

    2. the map on the custom post itself works fine

    3. the query is: [mashup height="200px" width="660px" show="query" show_query="posts_per_page=-1&post_type=projects"] and it’s on the home.php file with the do_shortcode(); function

    4. mappress pro version 2.38 (i guess it’s the most updated)

    ??

     

    #10249
    Chris
    Keymaster

    Hi,

    1. How are you are displaying the other 7 post types (that work) ?
    2. What happens if you just put the mashup shortcode in a post, rather than putting it in the home.php file?
    3. Are the posts public and published?  If they are private they won’t show up in query results.
    4. What happens if you deactivate your other plugins and use a standard theme (like ‘twentyeleven’)?

    If the above don’t help, please use the contact form to send me a login and I’ll take a look.

    #10250
    asafche
    Participant

    The other custom post types are shown the same way if i’m using them. in the normal function of the website the only 2 custom post types need to have mappress enabled.

    inside a post it is doing the same. the post are public and published, i’ve checked.

    tried to disable plugins and switch theme but i think that it’s wired that one custom post type will do fine and the others not.
    the problem is that my site is in hebrew. i guess it will be hard for you to manage…

    can this be because all of the othe custom post type was generated before i’ve installed mappress and only this one was registered after the mappress installation?

     

    #10251
    Chris
    Keymaster

    I really don’t know what would make those post types unique.

    I have several times seen conflicts with other plugins and themes that affected queries.  They can really difficult to troubleshoot, so I still think it’s always worth disabling plguins and switching the theme as a first step.

    You can also try just taking MapPress out this – try just running the query and printing the results instead.

    For example in yout template page do this instead of do_shortcode() :

    $wpq = new WP_Query("posts_per_page=-1&post_type=projects");
    print_r($wpq->posts);
    #10254
    zandergrin
    Participant

    I’m having the same issue -here’s my embed code. The custom post type is not showing up – I’ve checked all the settings as described above.

    I tried what you suggested in your last post and the print_r shows the post I am trying to get into the mashup.

    940, 'height'=>500, show=>"query", show_query=>"posts_per_page=2&post_type=directory");
    echo $mappress->shortcode_mashup($atts); ?>

    please advise

    #10256
    zandergrin
    Participant

    update – it specifially doesn’t work when I’m in an archive of a custom post type. so I’m in template “archie-post_type.php” and it just loads all posts.

    #10261
    Chris
    Keymaster

    @zandergrin:

    Hi,

    1.  What happens if you use a mashup directly in a post, without using do_shortcode()?

    2.  What happens if you disable your other plugins/theme?

    If you like, after doing the above send a login and I’ll try to troubleshoot it for you –  I haven’t been able to reproduce this problem on my test system.

     

    #10524
    zandergrin
    Participant

    Hi,

    Still got this problem – I make my mashups in the template
    disabling all other plugins doesn’t help
    I’m trying in a completely different theme and it doesn’t work there either. I;ve updated to the latest version – no help.
    Can you please attempt to recreate the problem by creating a custom post type – then an archive of that post type.

    #10526
    zandergrin
    Participant

    Ok – looks like an or change in the way the width is listed caused the problem. should be in inverted commas and with px

    here are my atts for anyone with a similar problem

    $atts = array(‘width’=>’700px’, ‘height’=> ‘455px’, show=>”query”, show_query=>”posts_per_page=-1&post_type=group_events”, poilist=>”true”, marker_title=>”post”, marker_body=>”excerpt”, directions => “none”, initialopeninfo=>”false”);

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.