Mashup not loading

Home Forums MapPress Support Mashup not loading

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #12401
    leografie
    Participant

    I’ve created two pages, each with maps.

    I’d like to have a mashup map on their parent page. Unfortunately I only get a “loading” message on the parent. Currently I’m using the shortcode:

    mashup query=”post_type=page” “post__in=93,107″ width=”630″ height=”820”

    Strangely, if I’m in the admin back-end and “view page” from there I see the page correctly loaded.

    Any suggestions?

    #12402
    leografie
    Participant
    #12403
    Chris
    Keymaster

    Hi, something in your blog is preventing the query from running – it’s directing the ajax query to a ‘page not found’ error.

    This is usually caused by a plugin or theme function that redirects the URL.

    Try deactivating your other plugins and switching to 2012.  You can reactivate them one by one to find the error.

     

    #12405
    leografie
    Participant

    I’ve tried what you suggest and the mashup map still fails to load with all plugins deactivated and using the 2012 (WordPress) theme. Have left it this way for you to take a look.

    The site is part of a multisite setup and uses the Pagelines Theme Framework.

    http://dewandelaar.nl/nz/accommodation-in-new-zealand/

    #12408
    Chris
    Keymaster

    Hi,

    I think the redirection is still occurring, perhaps the theme is active at the main site?

    Try this – it should return “0” but it returns the not found page from the main theme:

    http://dewandelaar.nl/nz/wp-admin/admin-ajax.php

    You could also try re-saving your .htaccess (go to the blog settings and save your permalinks, it’ll refresh it).

     

    #12410
    leografie
    Participant

    Hi Chris,

    Thanks for the help, with it I was able to isolate the issue to the .htaccess file.

    I had manually adjusted the file according to instructions from the ‘Better WP Security’ plugin, specifically their Hide feature that obscures the backend. The .htaccess rules cause the issue with mashups, not standard mappress maps.

    Here is the .htaccess code, perhaps you know something of how it may be amended so that the conflict does not occur. I’ve currently disabled the feature and removed the code so that the mashup functions as expected.

    <Code>

    <IfModule mod_rewrite.c>RewriteEngine OnRewriteRule ^login/?$ /wp-login.php?abcdefghijklmnopqrstu [R,L]RewriteCond %{HTTP_COOKIE} !^.*wordpress_logged_in_.*$RewriteRule ^admin/?$ /wp-login.php?abcdefghijklmnopqrstu&redirect_to=/wp-admin/ [R,L]RewriteRule ^admin/?$ /wp-admin/?abcdefghijklmnopqrstu [R,L]RewriteRule ^register/?$ /wp-login.php?abcdefghijklmnopqrstu&action=register [R,L]RewriteCond %{SCRIPT_FILENAME} !^(.*)admin-ajax\.phpRewriteCond %{HTTP_REFERER} !^(.*)dewandelaar.nl/wp-adminRewriteCond %{HTTP_REFERER} !^(.*)dewandelaar.nl/wp-login\.phpRewriteCond %{HTTP_REFERER} !^(.*)dewandelaar.nl/loginRewriteCond %{HTTP_REFERER} !^(.*)dewandelaar.nl/adminRewriteCond %{HTTP_REFERER} !^(.*)dewandelaar.nl/registerRewriteCond %{QUERY_STRING} !^abcdefghijklmnopqrstuRewriteCond %{QUERY_STRING} !^action=logoutRewriteCond %{QUERY_STRING} !^action=rpRewriteCond %{QUERY_STRING} !^action=registerRewriteCond %{QUERY_STRING} !^action=postpassRewriteCond %{HTTP_COOKIE} !^.*wordpress_logged_in_.*$RewriteRule ^.*wp-admin/?|^.*wp-login\.php /not_found [R,L]RewriteCond %{QUERY_STRING} ^loggedout=trueRewriteRule ^.*$ /wp-login.php?abcdefghijklmnopqrstu [R,L]</IfModule>

    </code>

    #12415
    Chris
    Keymaster

    Hi,

    I’m sorry, I don’t know how to emend the rule.  Maybe the security plugin folks can tell you?

    If it blocks access to ‘admin-ajax.php’, no front-end ajax calls will work (in this case the mashup).

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.