Mashup doesn't work in OSX Chrome/Safari, IE on a PC

Home Forums MapPress Support Mashup doesn't work in OSX Chrome/Safari, IE on a PC

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #12062
    sawdust
    Participant

    We are running the latest version of the plugin, 2.40.3. The individual maps display fine in any browser, but the mashup page shows the map only in Firefox. In Safari and Chrome it shows the loading gif and nothing happens. On a PC, Chrome and Firefox work, but IE doesn’t.

    The map is added using the following shortcode:

    [mashup query="all" zoom="2" center="12, 15" width="840" height="580"]

    I narrowed it down to the query statement. If I take query=”all” out of the shortcode all browsers display the map but no markers (obviously).

    The theme has wp_footer, we are using latest jquery, etc.

    The url is http://regionalsadmin.burningman.com/

    Thanks.

     

    #12063
    Chris
    Keymaster

    Hi,

    That page didn’t work for me in any browser.

    It seems like maybe the AJAX call to get the map data isn’t working.  MapPress calls the blog’s AJAX handler here:

    http://regionalsadmin.burningman.com/wp-admin/admin-ajax.php

    Normally that should just return ‘0’, but it’s returning the entire home page (you can try it – just enter it in your browser).  Is there some kind of redirect from the theme or another plugin?  Or is the AJAX url incorrect?

    If that doesn’t help, then it would help if we could rule out conflicts:

    1.  Deactivate ALL of your other plugins

    2.  Switch to the standard 2012 theme

    3.  Go to your ‘permalinks’ settings and save them again (to update the .htaccess file)

    4.  Check that page again – if the issue seems to be resolved, reactivate until you find the conflict.

     

     

     

    #12080
    sawdust
    Participant

    The browser behavior was a red herring; we had access to wp-admin disabled in the theme’s  functions.php for all but administrators and your call to admin-ajax.php wasn’t working because of that. It worked for me in FF because I was logged in as admin in FF.

    We had to install a plugin, WP Admin  No Show to get the same functionality without killing access to admin-ajax.php.

    Thanks.

    #19019
    francoisp
    Participant

     

    <span class="Y2IQFc" lang="en">It looks like I created a patch for some of your users.
    
    After having had a rather similar problem (modal which is not displayed when a point of the map is clicked for the users not connected in admin), I saw an error 400 of the ajax request "mapp_get_post". It made me think of a missing no_priv for the requested query. So adding the following line in the code, it worked for me: add_action ('wp_ajax_nopriv_mapp_get_post', array (__ CLASS__, 'ajax_get_post'));
    
    This code goes L 53, in mappress_map.php
    
    Regards, :)</span>

     

    #19020
    Chris
    Keymaster

    Hi,

    Thanks for catching that, the nopriv issue is fixed in the next version, 2.64.  It should be available tomorrow.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.