Mashup ajax error

Home Forums MapPress Support Mashup ajax error

Tagged: , ,

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #11286
    adrinmartin
    Participant

      Hi, I`m working on a mashup here: http://lanchaembarcaciones.com.ar/ventas-servicios/ that gives me an ajax error!

      I`m running WP 3.5 , map-pro 3.9.5 and also tryed disabling plugins and allocated more memory, without luck.

       

      Simple maps work fine : http://lanchaembarcaciones.com.ar/ventas-servicios/consesionarios-sea-doo/

      [mashup query="post__in=369,304,305" adaptive="true" width=100%]

      any clue?

       

      #11288
      Chris
      Keymaster

        Hi,

        Thanks for writing, I see the AJAX error – WP_Query is saying it’s not receiving an array for post__in.

        I’ll try to replicate this issue in my test system this afternoon and get back to you with an answer.

         

         

        #11298
        Chris
        Keymaster

          Hi,

          I found the problem (a bug in the query module) and it should now be fixed in version 2.39.6.

          You can download the new version from your account:

          http://mappresspro.com/account

           

          #11300
          adrinmartin
          Participant

            Thanks so much!

            worked perfect!

            #13437

            Hi,

            I am getting a similar ajax error on a mashup with about 100 icons http://www.ontheqt.ie – memory is being requested to >64Mb. Currently, the error is only being generated with the dashboard open, but I know from the way it has gone so far that a few more posts will cause the error without the dashboard open.

            Can you help here please as there seems to be a lot of overhead for a relatively small number of icons.

            Vincent

            #13440
            Chris
            Keymaster

              Hi,

              The current version of MapPress reads all the posts for the map, so that query dictates the memory usage/time.

              I think WordPress itself (with no plugins) uses around 40MB, so 64MB doesn’t sound extraordinary.

              If the problem is a memory limitation, you’ll need to increase your PHP memory or set a “posts_per_page” limit in the query. Here’s the codex entry:

              http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

              Please note that most hosts require you to edit the php.ini file, so just setting WP_MEMORY_LIMIT in wp-config.php won’t always work.

            Viewing 6 posts - 1 through 6 (of 6 total)
            • You must be logged in to reply to this topic.