Mappress Pro Not displaying on Custom Post

Home Forums MapPress Support Mappress Pro Not displaying on Custom Post

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #9499
    HDaniell
    Participant

      I’ve created a custom post type and selected it in the Map Press Pro display options but the editor doesn’t actually appear.  I’ve got standard Posts and my custom post type selected in the settings but the editor only shows on standard Posts and not on the custom posts.

      Any suggestions?

      Many thanks!

      #9502
      Chris
      Keymaster

        Hi, that’s strange, I haven’t heard of this problem before.

        You probably already checked these already, but just in case:

        – Make sure you’ve saved the otions
        – Make sure the MapPress meta box isn’t hidden for your post type (in the WP editor choose the ‘screen options’ button in the upper-right to enable/disable it)

        If that doesn’t work, how are you creating your custom post type? Do you have the register_post_type() code you used?

        #9504
        HDaniell
        Participant

          Hi,

          Yes, I’ve definitely saved the options.  The MapPress meta box option does not appear in the ‘screen options’ section for the custom post type.  And I’m not sure exactly how the post type has been registered as I used the “Types- Custom Field” plugin (http://wordpress.org/extend/plugins/types/).  But somewhere MapPress is “seeing” the custom post type because it’s offering me the option to display the editor there in the settings page… it’s just that once selected it doesn’t actually appear.

          I’d be happy to send over my login if you want to have a look around?

          Thanks!

          #9505
          Chris
          Keymaster

            Sure, send an admin login using the contact form and I’ll take a look.

            It might be related to the settings for the post type. I tried that plugin myself and created a type ‘test’ (plural, singular and slug all = ‘test’) using only the default settings. Then I checked the box in the MapPress settings – after that I was able to edit maps normally in the ‘test’ custom type.

          Viewing 4 posts - 1 through 4 (of 4 total)
          • You must be logged in to reply to this topic.