mappress.min.js errors after update

Home Forums MapPress Support mappress.min.js errors after update

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #17601

    Ok so I just updated my Mappress installation to the latest version, and that fixed one problem, but now I have a new one. I went to edit a map I had created in a post, and I couldn’t open it. So I thought maybe I’d delete it and re-create it, and while deleting worked, I can’t create a new map. When I try, I get this in my Chrome console:

    mappress.min.js:1 MapPress: Missing map name or container for map: mapp0
    log @ mappress.min.js:1
    mappress.min.js:1 Uncaught TypeError: t is not a function
    at Object.callback (mappress.min.js:1)
    at Object.success (mappress.min.js:1)
    at i (load-scripts.php:2)
    at Object.fireWith [as resolveWith] (load-scripts.php:2)
    at y (load-scripts.php:4)
    at XMLHttpRequest.c (load-scripts.php:4)

    I tried disabling all my other plugins to make sure it wasn’t a conflict with something else, and this error still happened.


    Hi, have you tried clearing your browser cache?

    If that doesn’t help, please use the contact form to send a login and I’ll take a look. I don’t have that error in my test system.


    Thanks. I didn’t think about caching, but clearing the cache seems to have cleared it up.

    I am having a different JS issue on the front end, and I don’t know if maybe I should create a new thread for it. But after updating, I noticed that a script on the front end that centered and zoomed in on the POIs on my mashup map has quit working. The map ID is mapp4, and the console is giving me messages like

    Uncaught TypeError: mapp4.getPoiById is not a function
    at HTMLDivElement.<anonymous> ((index):353)
    at HTMLDivElement.handle (jquery.js:3)
    at HTMLDivElement.dispatch (jquery.js:3)
    at HTMLDivElement.r.handle (jquery.js:3)

    In my script I plugged in an ID number just to make sure the variable I was using to generate the ID wasn’t the problem. I took the number from the “data-mapp-poi” attribute of a marker on the map, but I don’t know if that is the number I should be using. Did something change with the js to zoom POIs?


    That internal function has been removed.

    You could instead use getPois() which returns *all* pois, and then manipulate the one you want.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.