Map does not show after upgrade

Home Forums MapPress Support Map does not show after upgrade

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #12049
    bira
    Participant

      Hi Chris,

      I want to upgrade the MappressPro plugin on our site, so first did that on a development environment – only to find out not everything is working. I went through the changelog for all versions to see if I’m missing something, but can’t see it. Maybe you can help?

      The upgrade was from version 2.38 to the latest today.

      Here’s the map showing in 2.38 (under “Explore”): http://www.timesofisrael.com/the-jewish-planet/

      Here’s the same map missing in 2.40.3: http://dev2.timesofisrael.com/the-jewish-planet/

      The code generating this map in both cases is:
                      global $mappress;
                      $atts = array(‘show’=>’current’, ‘width’=>965, ‘height’=>543, ‘marker_title’ => ‘marker’, ‘marker_body’ => ‘title’);
                      echo $mappress->get_mashup($atts);

      Appreciate the help.

      Thanks,

      Bira

      #12054
      Chris
      Keymaster

        Hi,

        I checked this link:

        http://dev2.timesofisrael.com/the-jewish-planet/

        The plugin doesn’t seem to be installed properly.  Could you please check that you’re following these install instructions (assuming you’re using the ‘Pro’ version):

        http://mappresspro.com/install

        Also a note on the shortcode: parameters ‘marker_title’ and ‘marker_body’ are now ‘mashup_title’ and ‘mashup_body’, or you can just set them in the MapPress settings screen.

         

        #12058
        bira
        Participant

          Thank you for responding, Chris.

          1) I installed the plugin (it is Pro) exactly as stated – deactivated and deleted the 2.38 version, and only  then installed the 2.40.3.

          2) The plugin – and mashups – seem to work elsewhere. For example: http://dev2.timesofisrael.com/the-jewish-planet/?city=montevideo&type=hotels The difference in the code is:

          WORKING:
          global $mappress;
          $atts = array(‘show’=>’current’, ‘width’=>635, ‘height’=>357, ‘marker_title’ => ‘post’, ‘marker_body’ => ‘excerpt’);
          echo $mappress->get_mashup($atts);

          NOT WORKING:

          global $mappress;
          $atts = array(‘show’=>’current’, ‘width’=>965, ‘height’=>543, ‘marker_title’ => ‘marker’, ‘marker_body’ => ‘title’);
          echo $mappress->get_mashup($atts);

          So what’s changed is the atts, but I don’t fully understand what the new attributes are…

          Thank you 🙂

          Bira

          #12059
          Chris
          Keymaster

            Hi,

            1) The the page you just linked is loading the current version.  Search for ‘2.40.3’ in the source and you’ll see it:

            http://dev2.timesofisrael.com/the-jewish-planet/?city=montevideo&type=hotels

            However, the original, non-working page is still loading the old version – search for ‘2.38’ in the source and you’ll see it:

            http://dev2.timesofisrael.com/the-jewish-planet/

            I don’t know why one page works and the other doesn’t.  Perhaps a plugin is cacheing it or the server.  You can try deactivating your other plugins for a moment and restarting the server.

            2) The settings are available on the settings screen, so you don’t need to include them in your code unless they will be different for each map.  If you need to include them in code the parameter names and allowed values are in the documentation:

            http://mappresspro.com/mappress-documentation

             

             

          Viewing 4 posts - 1 through 4 (of 4 total)
          • You must be logged in to reply to this topic.