Entering in GPS coordinates changes to physical address

Home Forums MapPress Support Entering in GPS coordinates changes to physical address

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #15135
    tmoreno
    Participant

      Hello! I’m entering in GPS coordinates in a new map as well as adding several POI on the map, but whenever I enter the coordinates, they change to the closest physical address. Is there a way that I can change the coding so that I can enter gps coordinates without it changing to the address?

      #15138
      Chris
      Keymaster

        Hi,

        I’m not sure I understand. Usually if you edit a map and add a POI with coordinates like “-32,22” the plugin will keep those coordinates in the POI. They’re converted to an address only when you request driving directions.

        What coordinates are you entering? And where do you see it changing to a street address?

        #15139
        tmoreno
        Participant

          I’m entering coordinates such as 45.480564541633 -122.630691007179, which is in a field. After hitting enter, the POI changes to the address most closely associated to this gps point. I can easily drop a marker, which then shows and retains the lat/long coordinates, but that’s not the ideal behavior.

          #15142
          Chris
          Keymaster

            Are you entering this value in a custom field?

            If so: try configuring custom fields for lat/lng instead of (or in addition to) address in the MapPress settings. If you specify a lat and lng value, the plugin won’t geocode but it will use any value in the ‘address’ field.

            #15149
            tmoreno
            Participant

              No, just entering the coordinates into the map at the Mappress Add POI field for a standard wordpress page.
              Here’s a screenshot of where I enter the POI: http://reed.edu/test/tony/mappress/Screen%20Shot%202014-09-08%20at%208.31.22%20AM.png
              Here’s a shot after I enter the POI (note the change to an address): http://reed.edu/test/tony/mappress/Screen%20Shot%202014-09-08%20at%208.31.36%20AM.png

              #15150
              Chris
              Keymaster

                Thanks for the example, I think I see the problem now: there’s no comma between the latitude and longitude. If they’re not separated with a comma, the entry is treated as an address and gets (reverse) geocoded.

                To keep the original coordinates, try entering it like this:
                45.480238, -122.631310

                #15151
                tmoreno
                Participant

                  That would be it – thanks for the great support and patience. Wonderful plugin to work with!

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.