default zoom for geocoded maps from wp app

Home Forums MapPress Support default zoom for geocoded maps from wp app

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #10866
    James Proctor
    Participant

      Greetings — Your MapPressPro beta has very helpful geocoding settings, which we use to capture the lat/long from field postings using the WordPress mobile app. There is also a field for “Map Zoom,” but this field is not conveyed in a WP app post. I would appreciate a default (global) map zoom setting to be applied when there is no field specified for Map Zoom; this will ensure that your plugin works reasonably with the inherent capabilities/limitations of the WP mobile app.

      Many thanks,

      Jim P.

      #10867
      Chris
      Keymaster

        Hi,

        Good idea.  I’ve added this feature in 2.38.8, which will be released soon.

        #10927
        James Proctor
        Participant

          I’ve now tested the “New setting for default zoom to use when a mashup POI was added by lat/lng coordinates” in 2.38.8, and it indeed provides a default zoom as promised. Unfortunately, however, the way this has been programmed appears to result not only in a global setting for geocoded maps, but a permanent zoom that cannot be further edited! It is likely that some geocodes extracted from a WP app post will need to be zoomed in or out relative to this default zoom, yet when I edited a map the new zoom settings weren’t maintained. This is different from previous versions, where the map was originally zoomed all the way out but could be edited later to the desired zoom. Can this default zoom become a true default, in that any later edits to the map will override it?

          Many thanks,

          Jim P.

          #10930
          Chris
          Keymaster

            Hi,

            The default zoom setting isn’t saved with the map or the POI (or at least it’s not supposed to be saved).

            It’s intended as a workaround for not having zoom levels for individual POIs, in these 2 cases:

            1) Initially displaying a mashup that has only a single lat/lng POI

            2) The ‘center map’ link is clicked and there is only one lat/lng POI on the map

            You should be able to edit a map and save it at any zoom.  I just tried it with a single POI by lat/lng, and it seemed to work for me.

            I’m probably not understanding the issue.  Maybe you can explain further how to reproduce it, or send a login and explain how I can see it in your blog.

            #10931
            James Proctor
            Participant

              Yes, okay, so we’re on the same wavelength. What I did was the following:

              -I posted to our blog using the WP app.
              -I checked the posting, and the default zoom had been applied.
              -I then edited the posting’s MapPress map by rolling over Automatic, clicking Edit, zooming in or out on the map, and clicking Save.
              -I then clicked Update on the post, then viewed it. The zoom is unchanged from the default.

              Am happy to give you a login so you can try it yourself; will send separately via email.

              Many thanks for all your great support.

              Jim P.

              #10932
              Chris
              Keymaster

                Hi,

                Quick question: in the plugin settings do you have ‘Regenerate the map every time its post is published’ checked?  If so, it’ll ignore ALL edits (including the zoom) and re-create the map on each publish.

                If that’s not the issue, though, I’ll login and check it out…

                #10933
                James Proctor
                Participant

                  Ah, yes, you have it! I didn’t suspect this setting (which is not important to our site anyway), as the previous edits to zoom were preserved with this setting enabled.

                  I think it works now; will be in touch if questions.

                  Jim

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.