Can't see custom icons in 2.38.4-beta

Home Forums MapPress Support Can't see custom icons in 2.38.4-beta

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #9934
    iradoki
    Participant

      Hi,

      I had my maps working OK with 2.38.0 but needed to show some custom fields in the info windows. I’ve achieved this through 2.38.4-beta version, but now I seem incapable of using custom icons. I have moved the folder from the-plugin-folder/icons to uploads/mappress/icons, with no luck.

      Is there anything else I need to do?

      Thanks in advance!

      #9940
      Chris
      Keymaster

        Hi, do you have a URL for your page, or better yet a login so I can take a look?

        #9944
        ftadoug
        Participant

          Hi Chris,

          I just bought the pro version and have installed the latest beta. There is no/icons/ subdirectory in the root of the MapPress plugin directory of the beta version.

          There is an /icons/ subdirectory in the non-beta Pro version. I have tried creating the directory and added a png file, but nothing is showing up either on the wp page where the map is created or on the mappress settings page.

          Would like to use my own. Can you check it out?

          Thanks.

          Doug

          #9945
          ftadoug
          Participant
            #9950
            iradoki
            Participant

              Hi Chris,

              I have sorted it out. It was really quite silly; I’m using Roots theme which changes the ‘uploads’ folder (not the default /wp-content/uploads), so I just needed to place the mappress/icons folder (with my custom icons) in the actual uploads folder.

              Although it is pretty obvious, maybe you should consider rewording your documentation from

               If you have custom icons, you must move them from the /icons/ directory (under the MapPress installation directory) to /wp-content/uploads/mappress/icons.

              to something like

              If you have custom icons, you must move them from the /icons/ directory (under the MapPress installation directory) to /your-uploads-folder/mappress/icons (default is /wp-content/uploads/mappress/icons).

              Thanks for your interest!

               

              #9954
              Chris
              Keymaster

                Hi,

                iradoki: sorry you beat me to it, but I’m glad you got that figured out – I had no idea a theme would alter the uploads folder.  I’ll update the release notes to be a little clearer.

                ftadoug: the beta version expects the custom icons in the uploads directory, not in the plugin directory, as iradoki mentioned.  You can also see the release notes for beta 2.38.2:

                http://mappresspro.com/mappress-2-38-2-beta-available

                 

                 

                 

                #9962
                ftadoug
                Participant

                  Thanks for the note. I uploaded my icon to the correct directory and I can now use it. A couple of other issues have arisen.

                  1. After clicking my custom icon it actually disappears for a moment and then reappears. Tested it out on a few browsers and it happens on all of them. I tried one of your custom icons and the disappearing doesn’t occur.  http://dev.fresnohousing.org/about/properties/

                  2. I have included a .shadow.png file in the same directory (the first part of the file name matches the icon file name) but it isn’t displaying at all.

                  Do you have any thoughts on fixes?

                  Doug

                  #9974
                  Chris
                  Keymaster

                    Hi, I went to that link but the icons aren’t flickering for me and it looks like a custom shadow is showing.

                    I’m guessing they were the same problem.  Did you figure it out already or am I not understanding how to see the issue?

                    #9977
                    ftadoug
                    Participant

                      It is still an issue. I modified the php and javascript files so that I could include my images in your icon folders. For whatever reason that worked ok.

                      #9990
                      Chris
                      Keymaster

                        Hi,

                        It was a bug in the plugin.  I was able to reproduce the problem and fix it.  I’ve just released 2.38.5 beta which contains the fix.

                        I hope that helps, but please let me know if it doesn’t work for you.

                        #10018
                        barryn2000
                        Participant

                          “I modified the php and javascript files so that I could include my images in your icon folders”

                          Please share!

                          Why not have all the icons in a folder available in the dropdown?

                          I tried adding them to my uploads folder and nothing showed. I altered my uploads folder in settings to default and I was able to see the custom icon names (dot.png) available to show but no image…just the name. When I picked that icon name, it showed nothing and I was unable to change it back. I had to delete the POI totally and recreate it to get the standard list back.

                          I also tried to trick the system by renaming dot.png to arts.png and swaping them out with filezilla and it disabled the whole icon selection. I swapped them back and it worked again.

                          #10030
                          Chris
                          Keymaster

                            Hi Barryn2000,

                            The workaround shouldn’t be necessary.

                            Are you using 2.38.5?  A bug in 2.38.4 prevented the plugin from finding custom icons.

                            They must be uploaded to:

                            /wp-content/uploads/mappress/icons

                            The dropdown icon picker should show all the icons in that directory.  If it’s not working, feel free to send me a login and I’ll take a look.

                            #10039
                            barryn2000
                            Participant

                              Chris

                              The uploads folder in media settings is:

                              wp-content/themes/directorypress/thumbs

                              I tried using:

                              wp-content/themes/directorypress/thumbs/mappress/icons

                              wp-content/themes/directorypress/thumbs/uploads/mappress/icons

                              Neither worked…

                              I reset the site to the  default uploads folder:

                              wp-content/uploads/mappress/icons

                              that didn’t work either…

                               

                              I emailed you a screenshot. let me know when you have time and I’ll email you the login.

                              #10164
                              Chris
                              Keymaster

                                Hi,

                                For anyone else searching on this thread: WordPress offsers separate settings for the uploads URL and the uploads PATH.  They must be consistent (pointing to the same directory) in order for MapPress to find the icons directory.

                                #10425
                                David
                                Participant

                                  I’m having the same issue with 2.38.5 on one of my sites, but it’s working normally on the other.

                                  Both “Upload Path” and “Fileupload URL” are pointing to the same directory. There was no “mappress/icons” directory (I deactivated and reactivated Mappress in case it was something created on activation), so I created a new one and put the icon in there.

                                  Each site is on a different multisite installation and the plugin is only activated on a site-by-site basis (not netwok activation).

                                Viewing 15 posts - 1 through 15 (of 16 total)
                                • You must be logged in to reply to this topic.