Adding my custom icon

Home Forums MapPress Support Adding my custom icon

Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #10427
    signcarver
    Participant

    I have MapPress Pro.

    I am creating this page – http://ezdockdealer.com/company/find-a-dealer/ and i would like to add my own icon.

    I upload my icon (a gif file) into the wp-content/plugins/mappress-google-maps-for-wordpress/icons directory.

    I have read the documentation but i can not figure out what code i need to hook where.

    Currently in the calling file i have [mappress mapid=”1″].

    Can you please help?
    Thank you very much,
    Steve

    #10429
    Chris
    Keymaster

    Hi Steve, just edit your map.  When you are editing a POI on the map, click the ‘red dot’ icon in the upper-right of the edit box (where you enter the POI’s title and body).

    A dialog box should open with a list of available icons – and your custom icon should be one of them.

    #10430
    signcarver
    Participant

    Darn – i’m still doing something wrong. – neither the window with the standard icons nor the window with my icons shows my custom icon. I uploaded the icon as both a gif and as a png.

    Here is a link to the blank “my-icons” window.

    http://ezdockdealer.com/wp-content/plugins/mappress-google-maps-for-wordpress/icons/my-icon-window.jpg

    #10431
    signcarver
    Participant

    OK – i think i know what the problem is. The plugin only seems to show jpg files in the my icons window (i uploaded gif, jpg, png8 and png24 and only the jpg shows up)

    #10435
    Chris
    Keymaster

    Hi,

    The .png files should work too.

    If you’re using version 2.38, try this: put your new file in the icons directory.   Then go to the MapPress settings screen and save the settings (without making any changes).  That should force the plugin to refresh the icons list.

    If that doesn’t work, feel free to send me a login and I’ll take a look for you.  Please just tell me the name and directory of the file you expect to see.

    #10436
    signcarver
    Participant

    Hi Chris,

    no luck – sent you the login info through your Contact Me page on this site.

    There are 4 files in the icons directory (jpg, gif, png8, png24)

    Thanks very much for your help,

    Steve

    #10439
    signcarver
    Participant

    Hi Chris,

    You found the problem – totally my fault. I had not resized the icons properly (they were too large.)

    Thank you for taking the time to help me!

    Steve

    #10596
    sdedilizia
    Participant

    Hello, I installed the PRO version, which is located in the “plugins” not in the “uploads”. I have created custom icons and i put them by following the instructions, but it does not work. What am I doing wrong? thank you very much

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.