Reply To: POI Infowindow in 2.38.4

Home Forums MapPress Support POI Infowindow in 2.38.4 Reply To: POI Infowindow in 2.38.4

#9986
Chris
Keymaster

    Hi Stephen,

    Thanks for letting me know about these issues:

    1)  Google sets the width and height of the infoWindow automatically to fit the content.  If you have a lot of content it will make a big infoWindow.  You can try disabling the map zoom/pan controls so it will fit the map, or you can override the infowindow style to give it a hint about how big it should be.  For example, to limit the window to 200px width:

    .mapp-iw {  max-width: 200px; }

    The release notes for 2.38.4 explain how to set custom CSS.

    2) On some of the POIs it looks like the image was inserted manually into the POI body rather than as a thumbnail, and it seems like the HTML is not be valid.  For example, “Melnik” has this in the body:

    <img src='http://randomimages.ca/nblog/wp-content/uploads/2012/06/Melnik07.jpg' width=150px>

    There’s no height (so Google can’t figure out how big it is) and the dimensions should be in quotes:

    <img src='http://randomimages.ca/nblog/wp-content/uploads/2012/06/Melnik07.jpg' width='150px' height='150px'>

    The same thing also happens with images inserted as thumbnails, like “Melnik to Kovachevitsa”.   I think this is because WordPress writes out the thumbnail dimensions with any ‘px’ (for pixels) and Google doesn’t like that.  Your theme also has CSS to set the image size to ‘auto’, which may cause a conflict.  You could try remove this from the theme’s style.css:

    body .content img {max-width: 100%; height: auto; width: auto ....

    Or, you could add a width and height to the style ‘mapp-thumb’ which is applied to the thumbnails:

    .mapp-thumb {  width: 150px !important;  height: 150px !important; }

    3.  I’ve updated the CSS in version 2.38.5 to include an ‘!important’ modifier on the padding, I think this will fix the padding issue.

    4.   There’s a setting on the MapPress settings screen to let you pick which links to use, have you tried unchecking ‘zoom’?